All Changes




This page regroups all the changes that happened to Substance Alchemist, from new features to bug fixes.

Version 2020

2020.2.1 (2.2.1) Udon

(Released: July 21, 2020)

Added:

  • [Layers] In App Error message when Image to Material (AI-Powered) is out of memory

Fixed:

  • [Layers] Image to Material (AI-Powered) does not work with Specular/Glossiness workflows
  • [Layers] Crashes when out of video memory while using Image to Material (AI-Powered)
  • [Layers] Disk cache is not used for display when opening a stack
  • [Layers] Detection of Nvidia RTX 8000
  • [Layers] It is sometimes impossible to move a layer outside a Splatter input
  • [Layers] Disk cache is not used when inserting a stack in a stack
  • [Layers] Some channel usages are computed although they are not used
  • [Layers] Blank outputs are created sometimes when importing images
  • [2D View] Switching to another layer with Draw mode active blocks pan and zoom
  • [Content] Snow - 8bit issue on the normal map
  • [Content] Pavement Pattern - 8 bits issue on the normal map
  • [Content] Equalizer - 8 bits issue on the normal map
  • [Content] Gravel Generator - 8 bits issue on the normal map
  • [Content] Floor Tiles - Handle opacity and specular level
  • [Content] Blender cycles eeve export preset - invert normal map
  • [Content] Correct issue with huge images with Image to Material (AI Powered)
  • [Application] Crash when choosing "Backup and Restart" on database error
  • [Application] Crash when clicking quickly on the same asset
  • [Application] Rare crashes on exit
  • [Application] Crash when dropping files on the Welcome screen
  • [Application] Crash when a corrupted environment file is loaded
  • [Application] Rare crash when rapidly switching rendered asset
  • [Application] Freeze when exiting while an asset is computing
  • [Application] Rare crash on startup on macos
  • [Application] Deadlock when closing the application soon after startup
  • [Rendering] 3D view sometimes flickers
  • [UI] Color picker and random seed widgets are not aligned with the rest of the tweaks
  • [Rendering] Wrong computation time displayed
  • [Export] Some export presets are sometimes missing

Known Issues:

  • Usage of Image to Material (AI powered) on high resolution images can be slow
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Content Aware Fill filters are slow in high resolution
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Impossible to save twice the exact same material layer stack

2020.2.0 (2.2.0) Udon

(Released: June 15, 2020)

Added:

  • [Create] New Image to Material (AI powered) filter available on Windows and Linux
  • [Create] Rename Bitmap to Material to Image to Material (B2M)
  • [Image Import] New Material Creation Template Pop-up
  • [Image Import] New "Add a base material" option
  • [Image Import] Be able to drag and drop additional images in the Material Creation Template
  • [Image Import] Be able to remove images in the Material Creation Template
  • [Image Import] Assign channel to imported bitmaps automatically based on their filename
  • [Image Import] Be able to invert normal maps
  • [2D View] Introduction of a painting mode
  • [2D View] The painting tiles
  • [2D View] Set a greyscale value for the brush color
  • [2D View] Pan and zoom while painting
  • [2D View] X shortcut to invert brush greyscale value
  • [2D View] [ and ] shortcuts to change the brush size
  • [2D View] Ctrl (or Cmd) + Mouse wheel change the brush size
  • [2D View] It is now possible to modify the source position when using Clone Patch
  • [Layers] Shift + drag and drop to auto scatter atlases
  • [Layers] Alt + drag and drop inserts a material as a decal
  • [Layers] Expose easily transform matrices from Substance Designer
  • [Layers] Dropping textures in a non-empty stack automatically assigns to the correct channels
  • [Layers] New type of layer: Compound Filters
  • [Parameters] Support Substance string inputs
  • [UI] Added drop shadows for popups and menus
  • [UI] New Color Widget with right click options (clear, copy, paste)
  • [UI] New Image Widget with Painting tool option
  • [UI] Be able to paint over an imported image in an image widget
  • [Rendering] New default camera position
  • [Export] Substance files are exported for Substance Designer 2020.1.2 (10.1.2)
  • [Performance] Better application startup time
  • [Performance] Improve asynchronous tasks handling
  • [Performance] Improve layer stack performance when adding, removing or moving layers
  • [Performance] Image to Material (AI powered) runs faster on RTX GPUs
  • [Content] New meshes: Female T-Shirt, Male T-Shirt, Shoe
  • [Content] New Blend Mode - Per Channel Blend
  • [Content] Opacity blend height correction with 2 new parameters (height position and height scale)
  • [Content] Add Height Adjustments in Height Blend mode
  • [Content] Use Height information option in the Custom Mask Blend
  • [Content] New Perspective Correction Tool
  • [Content] Pattern Generator - Add a parameter to invert the pattern
  • [Content] Pattern Generator - Add a new parameter Override Material Details
  • [Content] New Decal filter
  • [Content] New Moss filter
  • [Content] New Cracks filter
  • [Content] New PBR Validate filter
  • [Content] New Floor Tiles filter
  • [Content] New Quilt Stich filter
  • [Content] Atlas Scatter - Add Custom Mask input to enable painting option
  • [Content] Dirt - Add Custom Mask input to enable painting option
  • [Content] CLO export preset
  • [Content] VStitcher export preset
  • [Content] Unity HDRP presets export a detailMap

Fixed:

  • [Layers] Imported images are loaded too many times
  • [Layers] Crash when creating a clone patch at the bottom of the stack
  • [Layers] Adding a material at the bottom of the stack makes it unstable
  • [Layers] Filter after image import works improperly
  • [Layers] workflow_type value is not updated when switching the workflow between projects with a custom filter
  • [Layers] Disable "remove layer" button when no layer is selected
  • [Layers] Crash when loading an asset containing a Clone Patch
  • [Layers] Normal to Height filter crashes on MacOs
  • [Application] Crash when loading back and forth environment maps
  • [Application] Performance issues when some graphics tablet driver is installed
  • [Application] EXR 32 bits files import are black
  • [Application] Crashes when loading and unloading assets
  • [Application] Crash when switching from explore to create
  • [Application] Target collection when saving a material is not from current project
  • [Application] Fix backup and restart
  • [Image Import] Properly import grayscale images
  • [Content] New filters for new matrix handling
  • [Content] Imported custom filters are visible in the quick access bar
  • [Content] Fix color shift with the Make it tile advanced filter
  • [Performance] Opening a color dialog is slow and recomputes the current layer
  • [UI] Keyboard shortcuts sometimes don't work
  • [2D View] Content Aware Fill needs a useless first click to work
  • [Resources] Folders in local disks are still watched for updates after removing them
  • [Resources] Deleting a linked folder from filesystem doesn't remove it
  • [Export] Custom usages in custom export presets are not exported
  • [Export] Exporting .sbsar file with special characters in path fails

Known Issues:

  • Repetetive recomputations of Image to Material (AI powered) can trigger a crash (out of memory)
  • Repetetive recomputations of the Delighter can trigger a crash (out of memory)
  • Usage of Image to Material (AI powered) on high resolution images can be slow
  • Usage of Image to Material (AI powered) on GPU with low VRAM can trigger a crash (out of memory)
  • Image to Material (AI powered) is not available on PBR Specular/Glossiness
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Content Aware Fill filters are slow in high resolution
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Impossible to save twice the exact same material layer stack

2020.1.1 (2.1.1) Tiramisu

(Released: April 01, 2020)

Added:

  • [Project] Export and import metadata
  • [Application] Ctrl+S now saves a preset in Explore
  • [Performance] Use render cache instead of recomputing saved materials for resolutions up to 2k

Fixed:

  • [UI] Fixed computing indicator in the viewport
  • [UI] Entering Negative values in sliders is fixed
  • [UI] Combo boxes: keyboard arrows and scrollbar now work
  • [UI] Keep the selected channel when switching between "Material Outputs" and "Layer Inputs" in the 2D view
  • [Layers] Fixed crash when adding custom channels in Base Material
  • [Layers] Crash when manipulating layers
  • [Layers] Custom channels are not displayed with a saved material
  • [Application] Fixed rare crash when importing an asset
  • [Application] Crash on exit
  • [Application] Combo boxes now show correct values when switching presets
  • [Export] Renamed Enscape preset to Enscape Revit
  • [Export] Importing an export preset after removing it works
  • [Export] Crash at export
  • [Rendering] Fixed rendering when the base color is in 16bit half float format
  • [Project] Do not crash when importing corrupted package
  • [Project] Handle 2019.1.4 to 2.x.x migration when Create has never been opened
  • [Project] Fix a crash when importing the same project twice
  • [Project] Fix a crash when importing projects
  • [Resources] Custom filters imported in previous versions work
  • [Resources] Materials with the same name no longer erase each other
  • [Resources] Crash when linking a local folder
  • [Resources] Starter Materials user-created folders are no longer removed after a restart
  • [Inspire] Fix material/collection drop area and add a warning message if using an unsaved material

Known Issues:

  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider

2020.1.0 (2.1.0) Tiramisu

(Released: March 12, 2020)

Added:

  • [Export] Export preset selction to pack your textures for renderers and game engines
  • [Export] Export preset to Unreal Engine 4
  • [Export] Export preset to Unity Standard
  • [Export] Export preset to Unity HDRP
  • [Export] Export preset to Blender Cycles/Eevee
  • [Export] Export preset to Arnold 5
  • [Export] Export preset to Corona Renderer
  • [Export] Export preset to Enscape
  • [Export] Export preset to Keyshot 9
  • [Export] Export preset to Redshift
  • [Export] Export preset to Vray Next
  • [Export] Export preset to Lens Studio
  • [Export] Export preset to Spark AR Studio
  • [Export] Export preset to PBR Specular Glossiness from PBR Metallic Roughness
  • [Export] New export UI
  • [Export] Remember Export settings
  • [Export] Import and manage your custom export presets
  • [Export] Delete and replace your custom export presets
  • [Export] Rename your custom export presets
  • [Export] Set the default export resolution to the current resolution
  • [Export] Add the choice to create a subfolder to the export location
  • [Export] Warning message before replacing existing files
  • [Application] New version numbering scheme
  • [Application] Open Create at launch, and change labs order
  • [Welcome Screen] New welcome banner
  • [Project] Open last project at launch
  • [UI] New combo box style
  • [2D view] F shortcut to focus in the 2d view
  • [Filters] Added support for alchemist::parameterVisibility tag in Substance graphs
  • [Filters] Have a global tweak to manage parameter visibility based on your workflow
  • [Resources] New command line option to setup resources and linked folders with a configuration file
  • [Version checker] Configuration of the version check
  • [Content] New starter materials
  • [Content] Bitmap to Material - Add the possibility to define the metallic channel (uniform, custom image import, color picking)
  • [Content] Adjustment - Add the support of the PBR specular/glossiness workflow
  • [Content] Atlas Scatter - New parameters

Fixed:

  • [Project] Crash when importing the same project twice
  • [Project] Fixed crash when importing and opening projects several times
  • [Application] Crash when loading an unnamed material
  • [Application] Recognize missing files when re-importing them
  • [Application] Fix random crash on shutdown
  • [Application] Fixed rare crash when unloading an material in Create
  • [Application] Fixed random crash when using UI controls
  • [Application] Fixed export of log files to the Desktop on Windows 10
  • [UI] Export panel has the wrong size when you open it in Create
  • [UI] Open project with a single click
  • [UI] Correctly set minimum and maximum slider values
  • [UI] Show label of the channel usages instead of ids
  • [UI] Clicking a material always opens/closes the tweak panel
  • [UI] Fix hidden layers colors
  • [UI] Welcome Screen buttons improvements
  • [Layers] Less unnecessary recomputes
  • [Layers] Crashes when using Clone Patch
  • [Layers] Selecting an image import layer no longer triggers a compute
  • [Layers] Clone Patch and Content Aware Fill layers no longer recompute when selected
  • [Channel settings] Enabling or disabling usages now trigger a rendering
  • [Resources] Prevent freeze when mass clicking on a stack in the library
  • [Resources] Performance hit when re-adding a previously added linked folder
  • [Resources] Fixed a crash when trying to open a deleted .sbsar file
  • [Performance] Avoid loading materials to access their parameters
  • [Performance] Backup assets only when used in a project or in an authored material
  • [Export] Fixed materials in export queue sometimes skipped or exported with wrong parameters
  • [2D View] Restored pan and zoom
  • [Content] Parquet Pattern takes into account the Ambient Occlusion channel
  • [Content] Paint - Display mask input when enabling custom mask
  • [Content] Stonewall Pattern - Remove possible banding effects in the normal map
  • [Content] Height Modulation - Correct double base color entries in the 2d view

Known Issues:

  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider

Version 2019

2019.1.4 (1.1.4) Sesame

(Released: January 30, 2020)

Added:

  • [Resources] Confirmation prompt when clearing a resources folder

Fixed:

  • [Layers] Move layers to two and more layers below or above
  • [Create] Allocation of enough VRAM budget to have good performances

Known Issues:

  • Importing a lot of resources can really slow down Substance Alchemist
  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Normal to Height filter can crash on MacOS

2019.1.3 (1.1.3) Sesame

(Released: January 28, 2020)

Added:

  • [Workflow] Support of multiple workflows
  • [Workflow] Support of PBR Specular Glossiness workflow
  • [Workflow] New Channel Settings panel
  • [Workflow] Workflow selection at project creation
  • [Channel Settings] Activate/Deactivate specific channel computation
  • [Channel Settings] Display list of custom channels available in the current material
  • [Channel Settings] Automatic computation of custom channels when required
  • [Channel Settings] Force/Block computation of custom channels
  • [Layers] New UI of material input placeholder in Atlas Scatter and Splatter filters
  • [Layers] Image Input parameter of a filter can be fed by underneath layers
  • [Layers] Display a notification when some layers are out of date
  • [Layers] Possibility to update to the latest version of outdated layers via the notification
  • [Project] New metadata fields at project creation
  • [Inspire] Generated variations are specific to a project
  • [2D View] Switch between the Layer inputs, layer outputs, and the material outputs
  • [Welcome Screen] Add Import project (.alch) option
  • [Preferences] New Preferences window to set cache location and analytics privacy settings
  • [UI] New UI buttons
  • [Performance] Overall improvement of the parallelization system
  • [Performance] Optimization of the number of material computes
  • [Engine] Substance Engine update
  • [Framework] Upgrade to Qt 5.13
  • [MacOS] Global improvements of macOS Catalina support
  • [Content] Adjustment filter - Normal intensity and invert parameters

Fixed:

  • [Layers] Unset Image Input parameter when deleting the layer
  • [Layers] Fix a crash when adding a clone patch layer
  • [Layers] Fix some crashes when blending layers stack materials in other layer stack materials
  • [Export] Channels selection for export is now respected
  • [Resources] Do not crash when navigating in the Resources panel
  • [Resources] Fix crash when importing corrupted Substance files
  • [Resources] Reduce the number of crashes when loading large folders
  • [Thumbnail] Thumbnail computation doesn't freeze the interface
  • [Image Import] Uniformization of image type supported across the application
  • [Preset] Save the description when creating a preset from an SBSAR
  • [Inspire] Fix image drag and drop
  • [Application] Fix crashes at exit
  • [Application] Fix crashes at the exit when exporting materials
  • [UI] Fixes and improvements
  • [UI] Rename temporary asset to "unsaved material"
  • [Content] Global update and cleaning of all filters

Known Issues:

  • Importing a lot of resources can really slow down Substance Alchemist
  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Normal to Height filter can crash on MacOS

2019.1.2 (1.1.2) Sesame

(Released: December 11, 2019)

Added:

  • [Layers] Save and Save as options are accessible via the interface in the layers stack toolbar
  • [Resources] Clearer breadcrumb in the Resources panel to navigate through folders
  • [Resources] Maintain back button pressed to access all upper folders
  • [Resources] Add reload of imported materials option to update them to the latest version
  • [Layers] Possibility to change the image in the Image import layer
  • [Layers] Possibility to define an image as a channel (base color, normal, height,...) in the Image import layer
  • [Content] New Atlas Scatter filter to scatter new atlas elements from Substance Source
  • [Content] New Oil Paint Effect filter
  • [Content] New Channels Generation filter to generate height, ambient occlusion and roughness from base color and normal maps

Fixed:

  • [UI] Reactivate tooltips on Layers stack toolbar
  • [UI] Fix issue when typing two decimals in a slider value
  • [Performance] Fix crash when switching quickly between materials
  • [Export] Switching to another material before the end of an export does not crash anymore
  • [Resources] Context menu is displayed on top of the material when you right-click on it
  • [Layers] The 'Click here' link is working when the layer stack is empty
  • [Presets] Remove save button in the tweak panel when it's a material created in Alchemist
  • [Tweak] Information message displayed when it's a material created in Alchemist
  • [Viewport] Default value of Specular Level texture is corrected to 0.04
  • [File Menu] Fix and rename Save and Save as option
  • [Engine] Update Substance engine version to avoid crash of some SBSAR files during import.
  • [Content] Tiling filter is working on the ambient occlusion channel
  • [Content] Crop filter is working on the ambient occlusion channel
  • [Content] Water filter modifies gain the height map
  • [Content] Correct tiling of the top material in the opacity blend mode
  • [Content] Height of the top material is preserved in the opacity blend mode
  • [Content] Possible to add a custom mask, custom pattern or a scale map in the Perforation filter
  • [Content] Height Modulation filter forces height and normal maps in 16 bits
  • [Content] Adjustment filter forces height and normal maps in 16 bits

Known Issues:

  • Importing a lot of resources can really slow down Substance Alchemist
  • Content Aware Fill filters are slow in high resolution
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific evalue in a slider
  • Normal to Height filter can crash on MacOS

2019.1.1 (1.1.1) Sesame

(Released: November 26, 2019)

Added:

  • [Blend] New opacity Blend mode
  • [Engine] New Substance Engine version

Fixed:

  • [Layers] Fix crash while deleting a layer that is still computing
  • [Layers] Fix crash while removing the bottom layer
  • [Layers] Fix crash while the material name contains special characters
  • [Layers] Stop computing every filters that use a widget
  • [Layers] Avoid crash while using Clone Patch and Content Aware Fill filters
  • [Layers] Fix crash while drag and droping a filter in a splatter input slots
  • [Resources] Fix crash while linking local folders or importing resources in Substance Alchemist
  • [Collection] Fix crash while switching rapidly between materials
  • [UI] Fix crash while value is null or not valid in tiling, displacement sliders on the viewport
  • [Inspire] Fix crash while accessing the Inspire tab
  • [Inspire] Fix crash while inspiring on a just saved layers stack material
  • [Performance] Heavy Substance materials and Filters (Tiling) compute faster
  • [Help] Fix export log file
  • [Content] Randomizer filter works on all channels
  • [Content] Multiangle workflow takes all scans into account
  • [Content] AO Blend correct blending
  • [Content] Curvature Blend correct blending
  • [Content] Color ID Blend correct blending
  • [Content] Custom Mask Blend correct blending
  • [Content] Fix Adjustment filter for roughness modification
  • [Content] Fix Base Material filter for custom normal channels upload
  • [Content] Fix Custom Import pattern of the Embossing filter

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to Height filter can crash on MacOS

2019.1.0 (1.1.0) Sesame

(Released: November 04, 2019)

Added:

  • [Project] Creation of a project
  • [Project] Introduction of the .alch file format that contains project data
  • [Project] Export a .alch project containing the collections and their materials
  • [Project] Import a .alch project
  • [Project] Open recent projects
  • [Welcome Screen] A welcome screen is displayed at the launch
  • [Welcome Screen] Create a project from the welcome screen
  • [Welcome Screen] Access the list of all your projects in the welcome screen
  • [Welcome Screen] Quick links to access the documentation, the about popup and license management
  • [File Menu] Integration of a file Menu
  • [File Menu] Access the project commands from the File tab and the save of the layer stack
  • [File Menu] Access the undo and redo commands from the Edit tab
  • [File Menu] The previous help menu moved in the file menu under the Help tab
  • [Layers] New architecture of the layer stack
  • [Layers] New UI of the layer stack
  • [Layers] Select the blend mode directly on the toolbar
  • [Layers] Access separately the blend parameters and the material parameters
  • [Layers] Add materials directly in dedicated inputs of the Splatter filter in the layer stack
  • [Layers] Change scan order directly in the Image import layer
  • [Viewport] Control of the camera field of view
  • [Viewport] Possibility to switch between orthographic or perspective camera
  • [Viewport] Display resolution and bit depth information for each channel
  • [Resources] Base Materials is opened per default
  • [Cache] Locate your thumbnail cache folder
  • [Cache] Locate your render cache folder
  • [Panels] Material Settings panel is temporarily hidden
  • [Workflow] Specular/Glossiness temporarily deactivated
  • [MacOS] Catalina OS version notarization
  • [Content] New version of the Delighter filter
  • [Content] New Image Content Aware Fill filter
  • [Content] New Material Content Aware Fill filter
  • [Content] Transform filter has a safe transform option

Fixed:

  • All previous bugs related to Create are invalid today with new UI and architecture release
  • Tooltips don't hide the icons in the top bar (3D, 2D, 2D/3D)
  • [Content] Splatter filter accepts Atlas with complete height map
  • [Content] Transform filter works on images (scan1, scan2,...)

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to Height filter can crash on MacOS

Beta

0.8.1-beta Quinoa

(Released: August 19, 2019)

Added:

  • Ability to send Substance Source assets from the launcher to Project Substance Alchemist

Fixed:

  • [Create] Some filters were listed in the quick accessor but not in the filter panel
  • [MacOS] Fixed some crashes at exit

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage is not recommended
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to height filter can crash on MacOS
  • Can still crash randomly when exiting on MacOS

0.8.0-beta Quinoa

(Released: August 08, 2019)

Added:

  • [Resources] Connect and mirror your material folders on your local disks
  • [Resources] Browse your materials folders and their subfolders
  • [Resources] Detach your material resources panel in a separate window to see your resources in full screen
  • [Resources] New Resources panel Layout to support folders and subfolders navigation
  • [Resources] Use the breadcrum to navigate through your folders
  • [Resources] Force the synchronization of your local folder with the Sync option accessible via righ-click
  • [Resources] Disconnect your local folder with the Disconnect option accessible via righ-click
  • [Manage] Display embedded tags of Substance files
  • [Manage] Add, edit and delete tags of your materials
  • [Manage] Rate your materials
  • [Layers] Support Panorama output
  • [Layers] You can delete Image inputs in the Image Import layer
  • [Layers] Automatic selection of the new added layer
  • [Layers] Automatic selection of the layer below after a layer deletion
  • [UX] Keep left panels visibility when switching to another Lab
  • [UX] Do not create a base layer or open the Material Workflow popup when importing images in a non-empty layers stack
  • [UI] New Textfield style
  • [UI] New SearchBox style
  • [UI] New Panel header style
  • [UI] New Busy indicator style
  • [UI] New Layers stack background style
  • [UI] Use Adobe Clean font
  • [UI] Remove eyedropper icon placeholder of color input parameter
  • [Performance] Busy indicator optimization
  • [Content] New Pattern Generator filter
  • [Content] New Blur filter

Fixed:

  • [Inspire] Fix crash when using more than 10 colors
  • [2D View] Fix scrollbar on the channel list of the 2D view
  • [Viewer] Fix crash when importing a non power of 2 environment map
  • [Content] Fix PNG import for custom pattern of Embossing and Perforation filters
  • [Export] Fix normal and height 16 bits per channel export
  • Fix an infinite loop when importing a material with two presets that have the same name
  • Fix long file path display in the Base Material Layer

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage is not recommended
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to height filter can crash on MacOS
  • Can crash randomly when exiting on MacOS

0.7.0-beta Pepper

(Released: June 13, 2019)

Added:

  • [Filters] Access quickly to your filters by pressing the space bar
  • [Filters] New dedicated panel to manage, browse and import your filters
  • [Metadata] Right click on a material to see its metadata
  • [Metadata] Right click on a material to see its location on your disk
  • [Sliders] Animate sliders when you hover them by pressing Ctrl
  • [Sliders] Stop and restart your sliders animation by pressing P
  • [Export] SBSAR export follows Substance Source guidelines
  • [License] Activate Substance Alchemist using an environment variable
  • [UX] File dialog remembers the last file path selected
  • [UX] Folder dialog remembers the last folder path selected
  • [UI] Update Resources panel UI
  • [UI] Update Search bar UI
  • [UI] Create New material icon is updated
  • [Help] URLs are updated to substance3d.com domain
  • [Mesh] A Cloth mesh is now available
  • [Content] New Corrosion Filter
  • [Content] New Oxydation Filter
  • [Content] New Moss Filter
  • [Content] New Dust Filter
  • [Content] New Brickwall pattern Filter
  • [Content] New Stonewall pattern Filter
  • [Content] New Wood Finish Filter
  • [Content] New Metal Finish Filter
  • [Content] New Snow Filter
  • [Content] New Randomizer Filter
  • [Content] You can now import your textures directly in the Base Material filter

Fixed:

  • Fix a crash when saving the layer stack
  • Possible to add a value above 1 in the environment rotation slider
  • Do not lose blend parameters when a blend layer is transformed back and forth from blend layer to material layer
  • Fix duplicates when generating variations of the same layer stack multiple times
  • When re-opening a material, Alchemist remembers the modified ranges (min and max) of your sliders

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage is not recommended
  • Custom Environment Import can become black
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider
  • Normal to height filter can crash on MacOS

0.6.1-beta Orange

(Released: June 13, 2019)

Added:

  • [Engine] Substance Engine update to be compatible with the latest Substance Designer version
  • [License] Update license folder for first installations
  • [Layers] Reload at any time your layer stack to update your custom filters

Fixed:

  • [Data Compatibility] Preventive fix to limit data corruption at upgrade time

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage is not recommended
  • Custom Environment Import can become black
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider

0.6.0-beta Orange

(Released: April 18, 2019)

Added:

  • [Metadata] See and fill materials metadata in a dedicated tab
  • [Collection] Create a collection directly from the search results
  • [Media Publishing] Export a board of a collection
  • [UX] Undo a tweak change or image import by pressing Ctrl+Z
  • [UX] Redo a tweak change or image import by pressing Ctrl+Shift+Z
  • [UI] New icons with a new style
  • [Performance] New Session manager to better handle the tabs switching
  • [Performance] Faster opening of the Image Import layer
  • [Content] New Metal generic material
  • [Content] New Rust material
  • [Content] New Stone generic material
  • [Content] Embossing filter update
  • [Content] Embroidery filter update
  • [Content] Paint filter update
  • [Content] Delighter filter update

Fixed:

  • [Content] Water filter is working in the Specular/Glossiness workflow
  • Fix greyscale radio button in the activation pop-up
  • Accept files containing coma character
  • Fix small font issues on pop-up windows
  • Fix transparency UI issue due to a conflict with the FXAA parameter of some NVIDIA cards
  • Remove the focus of the field after entenring a value in a slider
  • Allocate the minimum amount of VRAM to the delighter to reduce crashes
  • Fix window freeze when resizing the application window
  • Fixed a crash when the layer stack was deleted while being evaluated

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage is not recommended
  • Custom Environment Import can become black
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider

0.5.4-beta Nacho

(Released: March 26, 2019)

Fixed:

  • [Stack] Crash when removing a splatter layer
  • [Data] Asset database gets corrupted when application crashes
  • [Data] Substance Alchemist cannot start when the asset database is corrupted
  • Random crash when importing Substance materials

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance
  • Custom Environment Import can become black
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider
  • Default collection to save to can be empty

0.5.3-beta Nacho

(Released: March 19, 2019)

Added:

  • Search by material name in the Resources panel
  • [UI] Clone Tool new UI with brush size visualization
  • [UI] Select and delete hidden stages
  • [UI] New Textfield UI
  • [Help] Access Substance Source, Substance Share and Substance academy websites
  • [Content] New default materials with generators and atlas
  • [Content] Bitmap to Material Update
  • [Content] Dirt Update
  • [Content] Rust Update
  • [Content] New Embossing filter
  • [Content] New Embroidery filter
  • [Content] New Erode filter
  • [Content] New Gravel Generator
  • [Content] New Paint filter
  • [Content] New Parquet Pattern filter
  • [Content] New Pavement Pattern filter
  • [Content] New Perforation filter
  • [Content] New Splatter filter
  • [Content] New Textile Wear filter
  • [Content] New Transform filter

Fixed:

  • [Viewport] Sphere mesh with tiling x2 on X
  • [Viewport] Crash when loading your own environment
  • [Viewport] Environment map are now using the exposure value too
  • [Viewport] F shortcut doesn't reset camera angle
  • [Export] SBS export works with latest Substance Designer 2018.3.3
  • [Export] SBSAR export respects the same guidelines as Substance Source materials
  • [UI] Scrollbars can be dragged
  • Special characters are supported on folder and file paths
  • Thumbnail is re-generated when you're saving your material

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance
  • Custom Environment Import can become black
  • Tif images are not showing in Properties panel in the Image import layer
  • Coma or point can be ignored when typing a specific value in a slider
  • Default collection to save to can be empty

0.5.2-beta Nacho

(Released: March 07, 2019)

Added:

  • Detection and usage of the high profile GPU

Fixed:

  • Rotation parameter has a proper slider widget
  • Fix the blue color line visiblity when drag and dropping materials
  • Fix materials blending when dropping a material below the first layer
  • Plug image inputs only if a custom image path is not set

Known Issues:

  • Special characters in filepath prevent for saving of a material
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance
  • Crash when loading your own environment

0.5.1-beta Nacho

(Released: March 04, 2019)

Fixed:

  • Fix Crash report, bug report and licenses pop-ups

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance
  • Crash when loading your own environment

0.5.0-beta Nacho

(Released: February 28, 2019)

Added:

  • [Layer stack] Layer re-ordering
  • [Layer stack] Delete an hidden layer
  • [Layer stack] Import a material directly at the position of your choice
  • [Layer stack] Material input as a new filter parameter type
  • [Performance] Substance Engine budget is dynamic for better performances
  • [Performance] Better OpenGL performances especially on MacOS
  • [Data] Faster data upgrade after a new version is released
  • [Content] AI Delighter available on Windows 7 and Windows 8
  • [Content] AI Delighter available on RTX GPU

Fixed:

  • Fix possible crashes when quitting the application
  • Export Pop-up opens faster when exporting large collections

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance
  • Crash when loading your own environment

0.4.0-beta Muffin

(Released: January 17, 2019)

Added:

  • [Export] Substance archive (sbsar) export of your collection
  • [Export] Substance file (sbs) export of your collection
  • [Export] Export queue visible in the Export panel
  • [Export] Name your collection or material before export
  • [Data] Save As your material by pressing Ctrl+Shift+S
  • [Data] Save your material by pressing Ctrl+S
  • [Data] Collections and Materials are compatible across versions
  • [Data] Update your material layer stack with up-to-date filters
  • [Data] Hot reload of imported custom filters
  • [UI] Visual feedback in the viewport while it's computing
  • [UI] New button style
  • [UI] Save pop-up displays the name of the active collection
  • [UI] Modify source images of an Image(s) Import Layer
  • [Content] Custom usages are now supported
  • [Content] More images format are supported in image input parameters
  • [Content] New Tiling Filter named Make It Tile Advanced
  • [Content] Update of the Water filter

Fixed:

  • Bitmap to Material handles the Specular/Glossiness workflow

Known Issues:

  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Delighter is not supported on RTX GPU card
  • Fast visibility toggle of a Delighter stage will affect performance

0.3.1-beta Lasagna

(Released: December 17, 2018)

Fixed:

  • Generate a color variation with 10 color extracted crashes
  • Generate a color variation with a just saved layer stack crashes
  • Incorrect links on the Substance Alchemist version update pop-up

Known Issues:

  • Bitmap to Material doesn't handle the Specular/Roughness workflow
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance

0.3.0-beta Lasagna

(Released: December 12, 2018)

Added:

  • [Export] New Export pop-up
  • [Export] Export an entire collection
  • [Export] Export Bitmaps at the format of your choice
  • [Export] Export Bitmaps at the resolution of your choice
  • [Export] Export only the channels of your choice
  • [Export] Preview the estimation size of your export
  • [Export] Preview the available size on your disk before exporting
  • [UX] Actions on collection accessible using right-click
  • [UX] Allow to unset an image or an asset in Inspire
  • [UX] Substance Alchemist is launched maximized
  • [Assets] New way of saving your materials in order to keep them persistent with next versions
  • [Help] Access to the online documentation via the help menu
  • [Performance] Faster color variations on complex materials created with Substance Alchemist
  • [Performance] Reduce memory leaks when switching Labs
  • [Content] Scale checker to diagnostic the physical size of your material
  • [Content] Update Italien Venice Mosaic tile material
  • [Content] Update Moss splatter

Fixed:

  • No more default name when saving a material
  • Filters parameters are lost after saving a material and reopening Substance Alchemist
  • [Content] Fix from bottom and from top logic for AO and curvature blending

Known Issues:

  • Materials created with a previous version won't be available in the new one.
  • Bitmap to Material doesn't handle the Specular/Roughness workflow
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance

0.2.0-beta Kiwi

(Released: November 09, 2018)

Added:

  • Viewer Settings are saved from one session to another
  • Material Settings are saved from one session to another
  • Fast loading of the Properties Panel
  • [Log] Export log file via the help menu
  • [UI]New Sliders Style
  • [UI]Presets and Tweak panels are merged
  • [UI]New Thumbnails style
  • Displacement, Tiling and Shadows settings accessible directly in the viewport
  • [Content] New Default Materials
  • [Content] Moss Splatter update
  • [Framework] Update Substance Engine Framework

Fixed:

  • Deletion of your layer stack by switching Labs is fixed
  • Loading time values displayed in the viewport are correct
  • Material workflow default channels are correctly initialized
  • Disable Custom Mesh Import
  • Bitmap export
  • [MacOS] Closing Substance Alchemist can need a "Force to quit"

Known Issues:

  • Materials created with a previous version won't be available in the new one.
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance

0.1.1-beta Jam

(Released: October 24, 2018)

Added:

  • BaseColor Delighter is now available
  • Access Substance Alchemist information via the Help menu
  • Get notified when a new version of Substance Alchemist is available
  • The console is not visible anymore on Windows
  • New Thumbnails style
  • [MacOS] Substance Alchemist can be set in full screen
  • [Filter] Import Custom mask to manage the blending between two materials
  • [Filter] Control Moss scale
  • [Filter] Clone Patch update

Fixed:

  • Add an image in an image input in the parameter list updates outputs
  • Import Custom filter doesn't add a black Ambient Occlusion and a black opacity

Known Issues:

  • Materials created with a previous version won't be available in the new one.
  • [MacOS] Closing Substance Alchemist can need a "Force to quit"
  • Use of multiple delighters in one material is not recommended
  • Delighter crashes with older NVIDIA drivers (Less than 400.x)
  • Fast visibility toggle of a Delighter stage will affect performance
  • Material export can crash

0.1.0-beta IceCream

(Released: October 17, 2018)

Added:

  • Material Blend with 4 blend types (Height Blend, Sample Blend, Curvature Blend, AO Blend)
  • Introduce Caching mechanism to optimize layer stack re-calculations
  • Auto-selection of a material in Inspire if presents in the viewport
  • Normal format centralized in the Material Settings panel
  • Crop and Tiling Widgets controls (-90xB0,+90xB0, make square,...) cleaning
  • New Snow filter

Fixed:

  • Panel UI cleaning
  • Viewport flickering when resizing window and panels
  • Layer stack not recalculated when saved
  • Assets naming in the interface use labels instead of graph names

Known Issues:

  • Stretched liure by switching the layer visibility quickly
  • Focus resets Camera angle