Exploring the Substance Designer Interface


Substance Designer's Interface is split in 6 parts:

  • The Explorer
  • The Library
  • The Graph
  • The 3D View
  • The 2D View
  • The Parameters



The Interface


The Main Menu

The Main Menu bar appears either at the top of the screen on Apple's OS X...


...or inside the main containing window on Microsoft Windows. Both offer the same commands.


File Menu

New > New Substance - Creates a new, empty, Substance.

Open... - Open an existing Substance or Substance Package.

Recent Packages - Displays a list of recently opened Packages. Click on an entry to open it.

Save All - Saves all open Substances and Packages.

Reload Resources - Forces Substance Designer to reload all resources, including bitmaps and SVG data.

Reset - Reset Substance Designer to its default state.

Exit - Close Substance Designer.

Edit Menu

Undo - Undo last operation.

Redo - Redo last undone operation.

Tools Menu

Suspend Engine - Suspends the rendering engine. This can speed up editing of complex Substance graphs.

Flush Rendering Cache - Substance Designer caches the results of rendering each node to speed up later renders. Flushing the cache forces re-rendering of every node in the Substance graph.

Switch Engine... - Offers a choice of rendering engines, including multiple DirectX engines (Windows) and OpenGL (OS X) as well as the reference software ("SSE") engine.

Remote Engines... - Lets you select a rendering engine running on another computer to spread the rendering work.

Locate Player... - If you wish to use Substance Designer's integration with Substance Player, use this to tell Designer where Player is installed.

Preferences... - Opens the Preferences dialog box. (See Preferences section for details.) This dialog is accessed from the Substance Designer menu on OS X.


Windows Menu

New Explorer - Opens a new Explorer tab.

New 3D View - Opens a new 3D View tab.

Reset Layout - Resets the workspace to the default layout.

Packages - Show / hide the Packages panel.

Graphs - Show / hide the Graphs panel.

Parameters - Show / hide the Parameters panel.

3D Views- Show / hide the 3D Views panel.

2D Views- Show / hide the 2D Views panel.

Gallery- Show / hide the Gallery panel.

Help Menu

Online Documentation... - Opens your default web browser to the Online Documentation.Substance Academy

Substance Academy - Opens up the Tutorials section of the Allegorithmic website.

Welcome Screen... - Re-opens the Substance Designer Welcome dialog box.

About Substance Designer... - Displays information about Substance Designer.

Report a Bug... - Opens the bug report page on the Allegorithmic website.

The Main Toolbar

At the top you will see the usual window widgets and (on the Windows version), the main menu.

Immediately below this is the Toolbar, which provides quick access to key menu commands.

The buttons are, from left to right:

  • Add new Substance to current Package.
  • Add new Composite Substance.
  • Open Package(s). 
  • Save All.
  • Undo.
  • Redo.

The Panels

The main display is split into multiple panels. On the left are the Explorer and Gallery panels. In the top center of the window is the Graph panel, which is directly above the 3D Views and 2D Views panels. In the center of the window are the 2D Views (top), the 3D Views (lower left) and Graphs (lower right) panels.

Finally, we have the Properties panel displayed to the right of the window. This displays the properties—which Substance Designer refers to as Parameters—for Substances and their components.

Panels support multiple tabs—hence "Views" instead of "View". Additionally, each panel can be individually detached from the application’s main window—double-click on the dark gray title bar—and relocated to another display if you wish. (The same double-click action will restore the panel to its original location.) You can resize panels by dragging the dividers between them.

At the lower edge of the Substance Designer window is the Status Bar. This displays useful information, such as the cache state and a progress bar for the Substance renderer.

Common Toolbar Features

All the panes in Substance Designer have a couple of common toolbar icons. These are to the right of the top-most toolbar in each panel:

Persistence

The pin to the right makes the panel persistent. By default, Substance Designer will reuse existing panels to display items, rather than opening new tabs. For example, double-clicking on a Substance's graph in the Explorer will reuse the current Graph View tab when possible. However, if the Persistent setting is active, Substance Designer will avoid reusing that tab and create a new tab instead.

The downward-pointing triangle to its left opens a menu that may contain one or more commands specific to the panel. All panels include a "Persistent" option that provides the same functionality as the pin icon.

The Graphs panel's menu is shown below:

Toolbar Truncation

Sometimes, a toolbar doesn't always fit in the space available. In such cases, the toolbar is displayed in a truncated form, with the missing functions under a menu labeled as >>, to the right of the toolbar. Most of the toolbars in Substance Designer will truncate in this way.