Interface


This page provides an overview of the Substance Designer interface, listing each window and its purpose. You'll find a summary and a link to a page that explains each window in more detail.

Main Toolbar

The main toolbar lets you access extra menu's, like the Preferences window and has a few buttons to quickly create a new Substance graph and package.

  • File Menu
    This menu lets you create new Packages and resources, as well as save and close packages you are currently working on. Functions from this menu are also available as quick buttons on this toolbar.
  • Edit Menu
    Provides Undo and Redo functions (available as quick buttons below), as well as access to Preferences, for in-depth customisation.
  • Tools Menu
    Controls Substance Engine and lets you access the Plugin Manager.
  • Windows Menu
    Lets you hide or show any of the windows in Substance Designer (some are hidden by default), and lets you reset the window layout back to default.
  • Help Menu
    Provides access to extra information and online resoucres, such as Substance Academy or this documentation website.

Explorer


The Explorer window is your main way of interacting with any kind of file and resource in Substance Designer. It gives you more options than the File menu in the Main toolbar This is where you'll start and end every session in Substance Designer.

Graph View


The Graph Window is the most important window in Substance Designer. It displays the nodal networks of any kind of Graph that is available in Substance Designer (Substance Graphs, Functions, MDL) and lets you build and edit them.

Properties


The Properties window is the most technical window of Substance Designer. It is always context-sensitive and will present you with sliders, dropdowns and other elements that change the behaviour of your selected resource or Node.

2D View


The 2D View is the simplest previewing tool in Substance Designer. It works together closely with the Graph: if you double-click  any Node in the Graph View, the 2D View displays the visual result.

3D View

The 3D View is the most interactive and most advanced preview window in Substance Designer. Unlike the 2D View, it uses a number of different output maps to render a full material. This means you see all channels represented, such as Basecolor, Normal and Roughness.

Library


In the Library window you have access to all of Substance Designer's default content. To better understand the difference between Atomic Nodes and the Instance Nodes in the library, you should make sure to read Nodes Overview.