The Main Toolbar


The Main toolbar and menu's appear at the top left of the Substance Designer Window.

It consists of two parts: the drop-down main menus, and quick-access buttons. All quick access button functions can also be accessed through the File and Edit menu's.

Quick Access Buttons

  • New Substance Ctrl+N - Presents you the "New Substance Graph" window, then creates a new package with a Substance Graph.
  • New MDL Graph - Presents you the "New MDL Graph" window, then creates a new package with a MDL Graph.
  • New MaterialX Graph (Only with MaterialX plugin installed).
  • Open... - Ctrl+O - Open an existing Substance Package (.SBS, .SBSAR, .SBSASM).
  • Save All - Ctrl+Shift+S - Saves all open Substances and Packages.
  • Undo Ctrl+Z - Undo last operation.
  • Redo Ctrl+Y - Redo last undone operation.

File Menu

  • New Substance - Ctrl+N - Presents you the "New Substance Graph" window, then creates a new package with a Substance Graph.
  • New MDL Graph - Presents you the "New MDL Graph" window, then creates a new package with a MDL Graph.
  • Open... - Ctrl+O - Open an existing Substance Package (.SBS, .SBSAR, .SBSASM).
  • Recent Packages - Displays a list of recently opened Packages. Click on an entry to open it.
  • Save All - Ctrl+Shift+S - Saves all open Substances and Packages.
  • Reload Resources - Forces Substance Designer to reload all resources, including bitmaps and SVG data.
  • Exit - Ctrl+Q Close Substance Designer.

Edit Menu

  • Undo - Ctrl+Z - Undo last operation.
  • Redo - Ctrl+Y - Redo last undone operation.
  • Preferences... - Opens the Preferences Window. This dialog is accessed from the Substance Designer menu on OS X.

Tools Menu

  • Cancel Rendering - Esc - Stops current operation for the Substance Engine. Can be used to abort an unwanted, heavy operation.
  • Suspend Engine - Shift+Esc - Suspends the rendering engine. This can speed up editing of complex Substance graphs.
  • Switch Engine... - F9 - Offers a choice of rendering engines, including DirectX engines (Windows) and OpenGL (OS X) as well as the CPU software ("SSE") engine.
  • Locate Player... - If you wish to use Substance Designer's integration with Substance Player, use this to tell Designer where Player is installed.
  • Plugin Manager... - Opens the Plugin Manager window, where you can install, load and unload Python Plugins for Substance Designer.


Windows Menu

  • New Explorer - Opens a new Explorer tab. You can have multiple Explorers open.
  • New 3D View - Opens a new 3D View tab. You can Have Multiple 3D Views open.
  • New Library View - Opens a new Library tab. You can have multiple Libraries open.
  • Python Editor - Opens the Python Editor used to evaluate and create scripts.
  • Reset Layout - Resets the workspace to the default layout. All windows will be re-arranged, and some windows might be hidden again. Use in case of problems with program layout.
  • Explorer - Show / hide the Explorer Window(s).
  • Graph - Show / hide the Graph Window(s).
  • Parameters - Show / hide the Properties Window.
  • Console - Show/Hide the Console Window.
  • 3D View- Show / hide the 3D View(s).
  • Dependency Manager - Show/Hide the Dependency Manager.
  • 2D Views- Show / hide the 2D View(s).
  • Library - Show / hide the Library Window.

Help Menu

  • Online Documentation... - Opens your default webbrowser on https://docs.substance3d.com/ for reference and technical documentation.
  • Python API Documentation... - Opens your webbrowser on the local Python API docs.
  • News... - Opens a window with latest version's changelog.
  • Forum... - Opens your web browser on https://forum.substance3d.com/, to get in touch with the community and ask questions.
  • Substance Academy... - Opens your web browser on https://academy.substance3d.com/, for tutorials and training.
  • Substance Share... - Opens your web browser on https://share.substance3d.com/, to find and learn from resources created by the community.
  • Substance Source... - Opens your web browser on https://source.substance3d.com/, to access our subscription-service material resource library.
  • Report A Bug... - Open bug reporting window.
  • Export Log File... - Exports current log files to a compressed (.zip) file, to provide to technical support.
  • Give Feedback... - Opens your web browser on the Substance Designer uservoice feedback page.
  • Welcome Screen... - Re-opens the Substance Designer Welcome dialog box.
  • Manage License - Opens License management window, letting you change license info and see validity.
  • About Substance Designer... - Displays information about Substance Designer.
  • About Yebis - shows information related to Yebis 3D viewpot post-processing.
  • About iRay - Shows information related to Nvidia's iRay rendering engine.