GPU has outdated drivers


When launching Substance painter a pop-up window can appear mentioning that the GPU drivers are outdated. This message simply means the software requires a minimum version of the GPU drivers to be installed. We recommended updating the GPU drivers to the latest version available when possible to get the best working experience.

VendorLink
NVIDIA

http://www.nvidia.com/Download/index.aspx

  • GeForce : "Studio Drivers" (SD) version recommended.
  • Quadro : "Optimal Driver fro Enterprise" (ODE) version recommended.
AMDhttp://support.amd.com/en-us/download
Intelhttps://downloadcenter.intel.com/
Some computer may have two GPUs: an integrated one (like an Intel chipset) and a dedicated one (like an Nvidia graphic card). Both needs to be up to date.